Color Field

Bundle of Color Choice and Indicator fields, adding color-coding, custom icons, KPIs, progress bars and dynamic countdowns to any SharePoint item and view
Color Field, a component of Ultimate Forms, helps you color-code your list items and provides BI indicators.
  • WSS 3.0/SharePoint Foundation 2010 support, MOSS/Server not required
  • 2-in-1 bundle of Color Choice and Indicator field types
  • Color-coding for rows, column and choices
  • Icons for choice values
  • Data-driven KPIs
  • Progress bars for numerical and date/time values
  • Dynamic countdown to and from a date
  • Cross-browser support
  • Integrates into regular SharePoint views, no conditional formatting needed
  • Convert to and from regular Choice fields
  • Color-code your lists without using SharePoint Designer
  • Works with Smart Alert Pro, Smart Print Pro, Associated Tasks field and List Search web part
  • New: Color Choice field is editable in Datasheet view when used together with Smart List Pro
  • Localized into English, French, Spanish and German
SharePoint 2013 app version of this product is available in Office Store. It can be installed both on premises and on Office 365 sites.
Enter any number of choice values and assign a color to each of them. Now every item that uses one of the choice value will have the background color changed to that choice's color.
Feature Image Our Product SharePoint Native
Color-code items in views and display forms   Included  
Assign icon to choice values   Included  
KPIs, progress bars and dynamic countdowns   Included  
No need to use SharePoint Designer   Included  
Applied to all views   Included  
Convert to and from regular Choice fields   Included  
Cross-browser support   Included  
Compatible with Smart Alert Pro, Smart Print Pro, Expert Search and Associated Tasks Field   Included  
Localized into English, French, Spanish and German   Included  
Note: unless specifically stated otherwise, all products require only SharePoint Foundation 4.0/5.0. Microsoft SharePoint Server 2010-2016 is supported, but not required. All of our products must be installed as farm solutions.